Installing Ubuntu on ZBOX Zotac EN760

Reviews and other little ventures that don't quite fit into the other forums
Daniel Wee
Site Admin
Posts: 2052
Joined: Wed 25 Feb 25 2009 8:00 pm

Installing Ubuntu on ZBOX Zotac EN760

Postby Daniel Wee » Tue 21 Oct 21 2014 11:03 pm

Download unetbootin from from http://unetbootin.sourceforge.net

Insert USB stick and Erase all using Disk Utility (system app.)

Using unetbootin - select Ubuntu Netinstall (64-bit or 32-bit). Preference is 64-bit.

Commit to disk.

To upgrade to next release do:-

sudo do-release-upgrade

Insert usb stick into ZBox. Use DEL key to get into BIOS setting, and change boot order to USB as #1.

Proceed to boot. GRUB seems to fail so use LILO as bootmanager.

Easy Nvidia: http://ubuntuhandbook.org/index.php/201 ... untu-1504/

Get NVIDIA drivers from:-
http://www.nvidia.com/Download/index.aspx?lang=en-us

Choose Geforce 800M Series, GTX 860M, Linux 64-bit (or 32-bit), English (US)

Click search and then Download. The ensuing .run file needs to be moved to the Zotac either by way of SFTP or downloaded directly on the Zotac using Firefox. This will end up in the ~/Downloads folder.

sudo chmod +x N*.run
sudo service gdm stop
./NVIDIA..... <------- execute the file using full name

sudo service gdm start

If necessary, run:-

sudo apt-get -f install

Goto https://developer.nvidia.com/cuda-downloads

Download DEB package for Ubuntu 14.04 (or whichever is latest). Move file to ~/Downloads directory using SFTP or direct.

sudo dpkg -i cuda-repo-ubuntu1404_6.5.14_amd64.deb
sudo apt-get update
sudo apt-get install cuda

Edit /etc/profile and add the line:-

export PATH=/usr/local/cuda-6.5/bin:$PATH

see http://askubuntu.com/questions/451672/i ... untu-14-04


Install FFMPEG

sudo add-apt-repository ppa:samrog131/ppa
sudo apt-get update
sudo apt-get install ffmpeg-real

see http://www.sysads.co.uk/2014/07/install ... ntu-14-04/

Daniel Wee
Site Admin
Posts: 2052
Joined: Wed 25 Feb 25 2009 8:00 pm

Install OpenCV

Postby Daniel Wee » Tue 21 Oct 21 2014 11:25 pm


Daniel Wee
Site Admin
Posts: 2052
Joined: Wed 25 Feb 25 2009 8:00 pm

Install Skype

Postby Daniel Wee » Tue 21 Oct 21 2014 11:43 pm



Daniel Wee
Site Admin
Posts: 2052
Joined: Wed 25 Feb 25 2009 8:00 pm

Re: Installing Ubuntu on ZBOX Zotac EN760

Postby Daniel Wee » Wed 22 Oct 22 2014 11:28 pm

Use the following link to get CUDA/GPU supported NVIDIA drivers installed.

http://askubuntu.com/questions/451672/i ... untu-14-04

May need to remove and re-install some of the libopencv-*:amd64 packages in /var/lib/dpkg/info

Daniel Wee
Site Admin
Posts: 2052
Joined: Wed 25 Feb 25 2009 8:00 pm

Re: Installing Ubuntu on ZBOX Zotac EN760

Postby Daniel Wee » Fri 24 Oct 24 2014 6:04 pm

edit /etc/lilo.conf

add a line:-

lba32

and change

vga=794

save the file and execute:-

lilo -v
reboot

If using grub, upgrade from lilo to grub as follows:-

sudo apt-get install grub
sudo grub-install /dev/sda
update-grub

You also want to fix the resolution after doing this:-

http://ubuntuforums.org/showthread.php?t=258484

the key is the line ending with "ro quiet splash"

There's some interesting into here but doesn't seem to work. See reference to "xvga" keyword in comments:-

http://www.varesano.net/blog/fabio/conv ... ilo%20grub
GRUB_CMDLINE_LINUX_DEFAULT="splash xvga=1024x768x24"
GRUB_GFXMODE=1024x768x24

Daniel Wee
Site Admin
Posts: 2052
Joined: Wed 25 Feb 25 2009 8:00 pm

Re: Installing Ubuntu on ZBOX Zotac EN760

Postby Daniel Wee » Fri 24 Oct 24 2014 11:28 pm

create a file called gdmxrandr.sh in /usr/share/
You need to be root to do this.

#!/bin/sh
sleep 2
xrandr --output HDMI-0 --primary --mode 2560x1440

save and:-

chmod +x gdmxrandr.sh

In Desktop - call up Startup Applications and add a line for:-

/usr/share/gdmxrandr.sh

Daniel Wee
Site Admin
Posts: 2052
Joined: Wed 25 Feb 25 2009 8:00 pm

Google authentication requests

Postby Daniel Wee » Sat 25 Oct 25 2014 10:32 pm

If you're getting authentication requests that cannot be satisfied with correct passwords, try:-

Open seahorse (Passwords and Keys)
Select 'Login' under 'Passwords'
In the search window type 'gnome'
Delete all entries that begin with 'GOA google credentials for identity account_blahblah'
Close 'Passwords and Keys'
Open Settings --> Online Accounts
Delete the entry for 'Google' ( '-' button)
Add the entry back ('+' button) and do what the dialog says.
Close 'Online Accounts'

Daniel Wee
Site Admin
Posts: 2052
Joined: Wed 25 Feb 25 2009 8:00 pm

Re: Installing Ubuntu on ZBOX Zotac EN760

Postby Daniel Wee » Thu 30 Oct 30 2014 9:52 pm

When adding Bluetooth mouse - use PIN 0000 option rather than automatic PIN option. Not doing so will mean having to reconnect mouse every time you restart.

Also, do:-

sudo nano /etc/bluetooth/main.conf

and change AutoConnectTimeout = 0

possibly add to /etc/rc.local

rfkill unblock all

Daniel Wee
Site Admin
Posts: 2052
Joined: Wed 25 Feb 25 2009 8:00 pm

Re: Installing Ubuntu on ZBOX Zotac EN760

Postby Daniel Wee » Tue 04 Nov 04 2014 11:27 pm

Backing up to USB using Clonezilla

http://clonezilla.org/liveusb.php

Start with:-

http://tuxboot.org

Download and run tuxboot. That will install Clonezilla on the USB.


Return to “Other Stuff”

Who is online

Users browsing this forum: No registered users and 1 guest