FT8 on Linux/Ubuntu

This is the catch-all forum for anything related to radio life!!
Post Reply
Daniel Wee
Site Admin
Posts: 2328
Joined: Wed 25 Feb 25 2009 8:00 pm

FT8 on Linux/Ubuntu

Post by Daniel Wee »

There are a few settings that need to be done to successfully connect your radio to the Linux machine. These steps include:-

1. Identifying the correct serial port
2. granting permission to the user to that port
3. Identifying the correct audio devices
4. Configuring the FT8 client (JTDX, WSJT-X, FLRig etc.)

To identify the port, unplug (if you're already plugged in) the USB serial port device. In my case, this would be the USB connection to the radio. Once you have done this, issue:-

Code: Select all

dmesg
The correct port will show up at the bottom of the long list, usually as ttyACM0, ttyACM1, ttyUSB0, ttyUSB1. The client should list these if correctly installed. In the case of my ICOM radios, they show up in the list as:-

Code: Select all

/dev/ttyACM0
/dev/ttyACM1
The correct one to use for ICOM and most radios would be the first option.

Secondly, you will now need to grant permission to access these ports. To do so, issue:-

Code: Select all

sudo adduser daniel dialout
Instead of "daniel", you can use whatever your username is for which you will run the FT8 clients.

Lastly, you will need to tell the client which audio device to use. In my case, the device shows up as:-

Code: Select all

alsa_input.usb-Burr-Brown_from_TI_USB_Audio_CODEC-00.analog-stereo
alsa_output.usb-Burr-Brown_from_TI_USB_Audio_CODEC-00.analog-stereo
Post Reply